Jump to content

  • Curse Sites
Help
Regional FlagProblem purchasing gemsSource
avatar
celicynd.9420
Target Source
#1 -

I just tried purchasing gems, and I’m getting a card approval error. There doesn’t seem to be an issue on my bank side, has anyone else had this problem?

I’ve had no issues with purchasing from the store up until this point, and now none of my cards are working.

My wife is having similar issues with her account. None of her cards work either.


avatar
ArenaNet Poster
Target Source
#2 -

If you’re having these issues, please contact Support directly for help. Use the “Ask a Question” tab to submit a ticket.

It could be that you and your wife hit the limit on purchases. (The limits don’t reflect on you personally, but on the system as a whole, btw. And yep, that’s frustrating for you and for us, too!)

Also, Nahsavtoo suggested below, and I’ve seen it work for others: Delete your credit card information and re-enter it. This has worked quite a few times for players, particularly if they get the “all clear” from our Payments Team but still have issues. It won’t work for everyone, but it’s something you can try.