Jump to content

  • Curse Sites
Help
Regional FlagMail disappearing/never receivingSource
avatar
KaynonVa.2058
Target Source
#1 -

A couple days ago, my friend lent me roughly 10 gold so I could sell a precursor on the TP. He put it in our guild bank and I withdrew it from there. After selling my precursor and receiving my gold from the TP, I attempted to send the gold back to him. I decided to send it through the regular mailing system. It has been 4 days now, and my friend has not received the gold, or any of the other mail I have attempted to send him. I have tried several of his character names, as well as his account name, and I am unable to receive his mail also. Please respond and help me resolve my issue. I have sent in a ticket, with no response, as well as trying @Guildwars2 on twitter, with also no response. someone help? I’m concerned my account might be under investigation or something and is locking my mail, yet I have never glitched, bugged, or hacked anything. I’m quite worried.


avatar
ArenaNet Poster
Target Source
#2 -

Usually when this happens it is because the recipient has a full mailbox. We’ve found that clearing the box — completely if possible (after removing any items, of course) — is the way to make sure that the sent in-game mails arrive.

Please have your friend try this, and if it does not work, have him update his ticket to explain that he tried that step but it was ineffective. Of course if it does work, having him post that the situation is resolved, and closing the ticket, would be much appreciated.


avatar
ArenaNet Poster
Target Source
#5 -

This is the first step. Taking this step solves the problem solves nearly every case of non-receipt of mails. So please try this.