Jump to content

  • Curse Sites
Help
Regional FlagGame Keeps CrashingSource
avatar
Ruralgeek.3027
Target Source
#1 -

I just got the game digitally, and I can’t play for more than 30 minutes before a crash to desktop with errors like this: http://i.imgur.com/4u58n.jpg

It almost ALWAYS crashes upon changing zones, or going into a city. But I also notice it when I’m hopping around the starting zone.

My specs are

Windows 7 32-bit
16 gb of RAM
GeForce GTX 460
AMD Phenom II X4 965 3.4 GHz

Is this a RAM issue?


avatar
ArenaNet Poster
Target Source
#3 -

Hi Ruralgeek,

While we do have some suggestions for helping players work around this issue, ultimately we need you to understand that this is a limitation of 32-bit Operating Systems and not actually of Guild Wars 2. The main issue here is simply memory limitations inherent in 32-bit Operating Systems. From what you have mentioned, you have upwards of 16GB of RAM but due to how 32-bit operating systems work, you can only use 3.5 GB. The problem comes in the form of the additional video memory your graphics card has.

This is where it gets a little complex but the short version is that the additional memory can push your total available memory into negative numbers resulting in crashes or simply, “out of memory errors.” Some players have resolved this by upgrading to 64-bit operating systems and others have simply removed physical RAM from the system to bring the memory totals closer to values intended for that revision of Windows (32-bit). Obviously removing RAM from your PC is not an ideal solution but I wanted to give you all the information we have found regarding these issues. You can read more about this issue from Microsoft here: http://support.microsoft.com/kb/929605 but the important part is listed below:

“For example, if you have a video card that has 256 MB of onboard memory, that memory must be mapped within the first 4 GB of address space. If 4 GB of system memory is already installed, part of that address space must be reserved by the graphics memory mapping. Graphics memory mapping overwrites a part of the system memory. These conditions reduce the total amount of system memory that is available to the operating system.”

One solution presented by players being affected by this is to change the “Maximum pre-rendered frames” in the Nvidia control panel. To do this:

1. Right-click on your desktop and select “Nvidia Control Panel.”

2. Select "Manage 3D Settings.

3. Scroll down until you find “Maximum pre-rendered frames” and change it from “Use the 3D application settings” to “1.”

Once completed, click “Apply” to save your changes and try Guild Wars 2 again.