Jump to content

  • Curse Sites
Help
Regional FlagThe Steel Tide .. that bug that breaks itSource
avatar
Kiroth.4579
Target Source
#1 -

I’ve enjoyed leveling up my 80 warrior dude during the first days of GW2 (soo many people around!!) and of course doing the player story quests.. up until I got into Orr to do ‘The Steel Tide’ quest.
The bug in question is the tank bug, which you are supposed to control and fight the incoming hordes, which you can’t control because if you try turning the turret its wonky and kicks you out of the tank… basically it breaks the quest completely. Using the mortars next to the tank only helps a small amount but I always end up getting swamped with the risen it, so mortars don’t really help to be able to complete it.

Now I know that bugs take time to fix but I’ve been away from GW2 for a while, a few months, and had thought that by that time this major story killing bug would have been fixed. It obviously has not at all. Before I left I tried a few times to go back and play the quest to see if it was fixed.. left for a few months… came back… still not done.

Even the guild wars 2 wiki page for ‘The Steel Tide’ quest has the quest still being broken. I mean… this is the main story quest, not some side quest.

Anyway, it is a little confusing why this hasn’t been dealt with yet. I’m hoping, as I speak, this GW2 February will fix this story breaker once and for all. Will post later with the answer


avatar
ArenaNet Poster
Target Source
#2 -

For now, you can use the mortars instead. The objective completes after killing a couple of Risen giants. We’re working on the bug, but Indon’t have an ETA at this time, sorry.