Jump to content

  • Curse Sites
Help
Regional FlagHaving problems with ticket supportSource
avatar
Paulytnz.7619
Target Source
#1 -

Okay I have a 2 part problem. 1st of all I just purchased the Commander Book in game and used the book and noticed I did not get any new title or access to the Icon. So I logged out of the game and then back in hoping it would fix it. It did not.

So I came to the ticket support area on this website which I have used before with few problems and I get told my account name or password is incorrect. Yet I have logged in before with those details many times as they are exactly the same as my account name and password for my gw2 log in. So I asked to reset password and got told that I have been sent an email with a link to reset the password. No email as yet and there is nothing in the junk folder. What else can I do?


avatar
ArenaNet Poster
Target Source
#4 -

You really need to continue your discussions with Support. We cannot assist you with this matter on the forums, because at this point the team needs to verify your ownership of the account in order to assist you, and that information is kept confidential.

Simply reply to the ticket you have in the system and an agent will help you.

If you find you cannot access the support site, then send an email to [email protected] and the team should be able to get you onto your support account.


avatar
ArenaNet Poster
Target Source
#6 -

Thank you I managed to finally get a reply by using the “ask a question” option, I just hope that I have supplied enough info to be helped. One last silly thing; don’t feel like you have to answer it just a curiosity as I have seen it before when getting emails from you guys. Why would my email program say this:

“This message looks very suspicious to our SmartScreen filters, so we’ve blocked attachments, pictures, and links for your safety. " :p

Interesting question. Your security program (anti-virus, etc.) filter setting may be high enough that a lot of things are getting questioned or outright rejected. Now, I’m not recommending that you reduce your settings, because I sense that you can get the message without seeing the images. But if you want to enable the link, you’ll need to do that manually, from the sounds of it.

Have you tried adding our sending address to your address book, like a “trusted sender?” My email and security programs give me that option; perhaps yours do as well.