Jump to content

  • Curse Sites
Help
Regional FlagMassive drop in FPS since Windows 8Source
avatar
Jereguy.3498
Target Source
#1 -

Hey guys,
So as the title states I’ve lost quite a bit of performance. Typically running around Lions arch and in WvW before patch i was receiving between 50-60 FPS sometimes it would occasionally dip lower but it wasn’t a concern. Now I can’t even seem to hit 30 FPS.
Here are my system specs. The video card drivers are identical to what I was using before as are most other drivers unless they had a specific Windows 8 version.
Are there any specific tweaks I should be doing ? Any way I can make the game playable again?
Anyone else experience any issues like this?
Here are my specs:
Intel 3820 @ 4.9 Ghz
Asus Rampage IV Extreme
Sapphire Vapor X 7970 Ghz Ed. X 2 (Crossfire)
32 gig Corsair Ram (CMZ32GX3M24A-1866C9)
3 × 27′ 2560 × 1440P monitors running at 8052 × 1440


avatar
ArenaNet Poster
Target Source
#2 -

Hi Jereguy – Are you using s 32-bit or a 64-bit operating system? Additionally, did you re-install all of your motherboard drivers as well as DirectX?


avatar
ArenaNet Poster
Target Source
#10 -

Hi again Jereguy – I would recommend trying a couple of these tweaks to see if this improves your in-game performance at all:

1. Right-click on your desktop and select “Catalyst Control Center.”
2. Select “Preferences” and left-click “Advanced mode.”
3. Click the “Gaming” tab on left.
4. Select “3D Application Settings.”
5. Under the heading “Anti-Aliasing” checkmark “Use application settings” but do not check “Morphological filtering.”
6. Under the heading “Anisotropic filter” checkmark “Use application settings.”
7. Under the heading “Tessellation” checkmark “AMD Optimized.”
8. Under the heading “Catalyst A.I.” move the slider to “Performance.”
9. Under the heading “Wait for vertical sync” move the slider to “On, unless application specifies.”
10. Under the heading “Anti-Aliasing Mode” move the slider to “Performance.”
11. Click “Apply” to save these changes and then start Guild Wars 2.

Once loaded, access the “Graphic Options” window and make the following changes:

1. Change “Refresh Rate” to “60 Hz”
2. Change “Frame Limiter” to “60.”
3. Change “Reflections” to “None.”
4. Change “Render Sampling” to “Native.”
5. Enable “Vertical Sync” at the bottom.

Hope this helps!