Jump to content

Photo
- - - - -

GW2 Beta Client - Should I be able to reach the login screen

Beta Client

  • Please log in to reply
3 replies to this topic

#1 Akatriel

Akatriel

    Asuran Acolyte

  • Members
  • 51 posts

Posted 27 April 2012 - 10:55 AM

After downloading the client and clicking play, my computer just sits there and the GW2 beta client becomes unresponsive. No errors are thrown, and -diag seems to show no problems, but I've heard some people mention they could get to the login screen.

Having never got to the login screen myself, I'm just trying to make sure this is normal behavior in preparation for the start of the beta weekend event.

Should I be concerned/looking for reasons why this is happening/reporting this to Arenanet?
  • 0

#2 SeviE

SeviE

    Fahrar Cub

  • Members
  • 11 posts

Posted 27 April 2012 - 11:12 AM

Hey bro.

Have a look here http://www.guildwars...ut-wont-launch/

As for me i updated my video driver.

Edited by SeviE, 27 April 2012 - 11:12 AM.

  • 0

#3 Akatriel

Akatriel

    Asuran Acolyte

  • Members
  • 51 posts

Posted 27 April 2012 - 11:22 AM

Thanks, SeviE. I'll try the driver rollback and update as mentioned!
  • 0

#4 Akatriel

Akatriel

    Asuran Acolyte

  • Members
  • 51 posts

Posted 27 April 2012 - 11:37 AM

Worked like a charm. Perhaps there should be a beta client issue/fix sticky section.
  • 0





Also tagged with one or more of these keywords: Beta, Client

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users