Jump to content

  • Curse Sites
Help
* * * * * 1 votes

Skill Delay Issue

skill delay issue

  • Please log in to reply
18 replies to this topic

#1 Amadeuz

Amadeuz

    Asuran Acolyte

  • Members
  • 70 posts
  • Guild Tag:[TA]
  • Server:Eredon Terrace

Posted 27 August 2012 - 10:30 AM

Is it just me?  or anyone have a skill delay issue? I feel like after I activate the skill, it seems delay 1- 1.5sec til it comes out. It isn't instant cast and cause a lot of problem for me. I can't effectively use the skills, while I have to wait 1 sec for skills to come out during the fights, especially the combat in spvp is really fast pace, even one second in GW2 PVP is still valuable.

Other than that my character controlling is smooth, I can instantly turn left, turn right, dodge. The only problem for me is skill delaying and I don't know how to fix this.

#2 HigoChumbo_

HigoChumbo_

    Fahrar Cub

  • Members
  • 34 posts

Posted 27 August 2012 - 10:36 AM

View PostAmadeuz, on 27 August 2012 - 10:30 AM, said:

Is it just me?  or anyone have a skill delay issue? I feel like after I activate the skill, it seems delay 1- 1.5sec til it comes out. It isn't instant cast and cause a lot of problem for me. I can't effectively use the skills, while I have to wait 1 sec for skills to come out during the fights, especially the combat in spvp is really fast pace, even one second in GW2 PVP is still valuable.

Other than that my character controlling is smooth, I can instantly turn left, turn right, dodge. The only problem for me is skill delaying and I don't know how to fix this.

I have the same problem but sometimes is more sever than others wich brings me to think that those are internet issues. It seems (not confirmed tho) that it happens more int he overflow servers, or when your server/zone has many people in.

It sucks because some people has the same isp and speed hired and has no problems.


And yes, i already stopped downloading porn =)

#3 AsgarZigel

AsgarZigel

    Vanguard Scout

  • Members
  • 476 posts

Posted 27 August 2012 - 10:52 AM

Many skills (even melee ones) have a small cast time if you didn't notice that.
Or do you mean lag? It lagged sometimes for me the first day, but not much after that.

#4 Lumm

Lumm

    Vanguard Scout

  • Members
  • 384 posts

Posted 27 August 2012 - 10:56 AM

Two things:

(1) The servers have been more laggy than during any BWE. Since BWEs were smooth sailing I assume that this will be ok within a week or two.

(2) Since there is no global cool down people assume that all abilities are instant - they are not. Some are but most weapon abilities for example have 'cast times' locked to the animation. So once you have a good feel for your profession and weapon you are better off looking at the avatar rather than the UI.

I do not know if you suffered from (1) or (2) but I talk to alot of people that are not aware of (2).

#5 Raxzor

Raxzor

    Vanguard Scout

  • Members
  • 159 posts
  • Location:United Kingdom
  • Server:Gandara

Posted 27 August 2012 - 11:00 AM

I think it is small lag spikes from server. I have been getting it also on the odd occasion.

#6 thable

thable

    Asuran Acolyte

  • Members
  • 145 posts

Posted 27 August 2012 - 11:07 AM

I had this problem really bad. I sometimes had about 5 seconds before a skill would activate. I always seem to have a pretty high ping in games, but this seemed ridiculously bad. I did a ping test on my pc, and another on my netbook. Weirdly my netbook had a low ping wheras my pc had a high one. So I had a fiddle around in the device manager, disabled the microsoft wifi miniport adapter, and suddenly... no more latency! Must have been a driver conflict with my wireless card.

Not sure if this will solve your problem though. Even now there's a tiny bit of a delay between pressing the skills and them working, but I think that's down to all the strain on the servers at launch.

#7 The Kindly Man

The Kindly Man

    Asuran Acolyte

  • Members
  • 118 posts

Posted 27 August 2012 - 11:14 AM

It's lag.

And it's really, really annoying in situations where you need to dodge/react/etc.

#8 auxili

auxili

    Vanguard Scout

  • Members
  • 373 posts

Posted 27 August 2012 - 11:15 AM

It's lag on Arenanet's side. It's not your fault.

#9 IST

IST

    Vanguard Scout

  • Members
  • 154 posts
  • Location:Aotearoa
  • Guild Tag:[Hobo]
  • Server:Sea of Sorrows

Posted 27 August 2012 - 11:28 AM

Well I'm in New Zealand... and if anyone should be lagging a bunch, it should be us.. but I have not noticed any abnormal cast times/delays etc...and I've been looking for them (lag hunting), seriously well optimized game in the net code.

#10 bcbully1

bcbully1

    Fahrar Cub

  • Members
  • 34 posts

Posted 27 August 2012 - 12:03 PM

Not so much as ability delay, but mouse turn delay. I can click my right mouse button, slide my cursor all the way across the screen from right to left, and sometimes my toon wont move. This is the killer for me.

#11 Corwin

Corwin

    Fahrar Cub

  • Members
  • 26 posts

Posted 30 August 2012 - 10:06 PM

Yeah man. I just started playing the game and there's just something that feels wrong about the skills. I definitely notice a delay, but it seems only when I'm near other people. Also Elementalist Burning Retreat spell causes me to teleport back and forth. Weird. It's like it's "out of sync" a bit, feels clunky and not very responsive.

Edited by Corwin, 30 August 2012 - 10:37 PM.


#12 Mightylink

Mightylink

    Vanguard Scout

  • Members
  • 214 posts
  • Location:Canada
  • Guild Tag:[OMNI]
  • Server:Dragonbrand

Posted 30 August 2012 - 10:35 PM

There is always a delay, thats called playing online, all games have it, some just hide it by playing your attack animation right away and showing "fake" damage until it gets through to the server. GW2 doesn't do that, it shows you the delay in real time.

#13 Zenh

Zenh

    Vanguard Scout

  • Members
  • 213 posts
  • Server:Crystal Desert

Posted 30 August 2012 - 10:55 PM

It's server lag. After a few weeks when things stabilize it should be better. I haven't had much of any lag outside in the world in PvE, but I've had 1-2 second skill delays in WvW.

Edited by Zenh, 30 August 2012 - 10:56 PM.


#14 BuzWeaver

BuzWeaver

    Vanguard Scout

  • Curse Premium
  • Curse Premium
  • 209 posts
  • Location:Atlanta, GA USA
  • Guild Tag:[OTG]
  • Server:Yak’s Bend

Posted 30 August 2012 - 11:22 PM

I noticed it more last night than any other time. I'm guessing its Connection Communication bottle necking.

#15 Winchestur

Winchestur

    Fahrar Cub

  • Members
  • 38 posts
  • Server:Darkhaven

Posted 31 August 2012 - 06:53 AM

Never had any troubles until tonight.  Asked some guildies and they didn't seem to notice.  At first I thought my characters were moving slower than usual.  Still do.  But later I noticed a 1-2 second delay on all my abilites, dodges, interacting (looting, talking to npcs,etc.)  Everything was delayed.  I noticed it on both overflow and my regular server.  Hope its cleared up soon

#16 Bleary

Bleary

    Asuran Acolyte

  • Members
  • 150 posts

Posted 31 August 2012 - 06:55 AM

This happened to me on overflow a couple times. I think it maybe server lag, all mmo's have it during periods of high-traffic. As players spread out it'll be less and less noticeable.

#17 Frescote

Frescote

    Pale Tree Seedling

  • New Members
  • 6 posts

Posted 31 August 2012 - 06:57 AM

This is also caused by your abilties not interrupting your auto-attacks, so you'll have to wait for your AA to finish for the server to go to the queue to get your skill to cast it.

#18 AsgarZigel

AsgarZigel

    Vanguard Scout

  • Members
  • 476 posts

Posted 31 August 2012 - 07:03 AM

Yeah the overflows often lag, but the normal servers usually don't, or at least not much.

#19 embty

embty

    Fahrar Cub

  • New Members
  • 11 posts

Posted 31 August 2012 - 11:04 AM

Yeah theres too much lag problems atm really upsets me





Also tagged with one or more of these keywords: skill, delay, issue

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users