Jump to content

  • Curse Sites
Help
* * * * * 1 votes

Gw2 Setup crashing


  • Please log in to reply
37 replies to this topic

#1 RedWings

RedWings

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 27 August 2012 - 07:44 PM

A friend of mine is having trouble installing Guild wars 2.  He downloaded the gw2setup.exe off the official site and launched it.  He gets to the white launcher screen and it starts to download then around 10mb (10025kb or something) it crashes leaving no error or info.  We've tried turning firewall off, allowing permissions via norton/read only modes, DLing gw2.exe, placing everything in one folder.  We've tried almost everything and nothing has worked.  All his hardware is compatible and the problem might be that he is running bootcamp with windows 7 on his mac.  If  anyone has had this problem and fixed it or knows a fix please post below.  Thanks!

#2 carmichael

carmichael

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 28 August 2012 - 04:26 PM

Same problem I have been having, today I even went out and bought the game on a disk. Now I have spent over 140$ and the game still wont install. Running bootcamp with windows 7 on a brand new mac just like your friend. I have found NO solutions to this problem and arenanet has been silent on it.

#3 Velicia

Velicia

    Vanguard Scout

  • Members
  • 157 posts
  • Location:England
  • Guild Tag:[BoD]
  • Server:Seafarer’s Rest

Posted 28 August 2012 - 04:32 PM

Have you updated any graphics drivers since installing?
I had this problem back in the stress tests, I had to roll back to certain drivers to get it to work each time (Nvidia 302.74 I think).

In the end I did a clean install of the graphics drivers and it fixed that problem.

#4 carmichael

carmichael

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 28 August 2012 - 05:30 PM

I have tried backdating video drivers and that was unsuccessful, My drivers are up to date as we speak however.

#5 mattie7

mattie7

    Pale Tree Seedling

  • New Members
  • 2 posts

Posted 28 August 2012 - 06:02 PM

I have this same problem. I put the DVD in and it starts downloading straight away but then when it gets to 10 mb 10025 or 10028 it just crashes. Not sure whats going wrong.

#6 Havencha0

Havencha0

    Pale Tree Seedling

  • New Members
  • 2 posts

Posted 29 August 2012 - 12:04 AM

Same can't even get pass 10mb need help :qq:

#7 Havencha0

Havencha0

    Pale Tree Seedling

  • New Members
  • 2 posts

Posted 29 August 2012 - 01:44 AM

Alright I figured it out and it worked for me, so what you have to do is go to start and right click computer and go to properties after that go to advanced and it should be under performance and then you click advance. The screen should be at performance options go to virtual memory and click change set the page file to system manage and you should be able to download.


Explains it a hell lot better than me: http://www.guildwars...ng-beta-client/

#8 carmichael

carmichael

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 29 August 2012 - 02:35 AM

View PostHavencha0, on 29 August 2012 - 01:44 AM, said:

Alright I figured it out and it worked for me, so what you have to do is go to start and right click computer and go to properties after that go to advanced and it should be under performance and then you click advance. The screen should be at performance options go to virtual memory and click change set the page file to system manage and you should be able to download.


Explains it a hell lot better than me: http://www.guildwars...ng-beta-client/


That didn't work for me unfortunately, thank you for the suggestion though. Has anyone received anything from Arena Net concerning this issue?

#9 TurlteEagleSpermFish

TurlteEagleSpermFish

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 29 August 2012 - 02:45 AM

I'm having the same problem. I've tried almost every thing I can think of. I'm losing hope.

#10 Anbukakashi

Anbukakashi

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 29 August 2012 - 03:16 AM

Im having the same issue im really getting upset

#11 TurlteEagleSpermFish

TurlteEagleSpermFish

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 29 August 2012 - 03:19 AM

I've looked everywhere and still nothing that fixes my problem. If anyone could help please do.

#12 TurlteEagleSpermFish

TurlteEagleSpermFish

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 29 August 2012 - 03:51 AM

All right, so I've finally got mine to work. Go to your control panel, system and security, under windows upates, check for updates. download even the optional ones. Restart and wala. Hopefully it works for the rest of you.

#13 mattie7

mattie7

    Pale Tree Seedling

  • New Members
  • 2 posts

Posted 29 August 2012 - 04:30 AM

View PostHavencha0, on 29 August 2012 - 01:44 AM, said:

Alright I figured it out and it worked for me, so what you have to do is go to start and right click computer and go to properties after that go to advanced and it should be under performance and then you click advance. The screen should be at performance options go to virtual memory and click change set the page file to system manage and you should be able to download.


Explains it a hell lot better than me: http://www.guildwars...ng-beta-client/

I also tried this and it didn't work for me but thanks for the idea. I am now trying the windows update suggestion I do have quite a lot of updates to install so hoping this could be a way to get it to work.

#14 brunpal

brunpal

    Fahrar Cub

  • Members
  • 24 posts

Posted 29 August 2012 - 05:36 AM

View PostTurlteEagleSpermFish, on 29 August 2012 - 03:51 AM, said:

All right, so I've finally got mine to work. Go to your control panel, system and security, under windows upates, check for updates. download even the optional ones. Restart and wala. Hopefully it works for the rest of you.
It should not be necessary to update windows. All this is doing is acting as a download manager, or possibly a torrent program. It's not reasonable that this is failing to download at all. It's not a complex operation.

I could see it necessary to update windows or drivers in order to play the game, or in order to install the game. This isn't even installing the game yet! This is pre-install. This is downloading files. This hasn't been a issue for decades. If I have to update/reinstall/make any change to my OS at all just in order to get a download manager to work then I'm going to be returning the game instead. Failing at the hard stuff is one thing, but failing at the easy and basic is unacceptable.

#15 brunpal

brunpal

    Fahrar Cub

  • Members
  • 24 posts

Posted 29 August 2012 - 07:07 AM

I have a solution:

1) Download Gw2Setup.exe using your web browser
2) Run Gw2Setup.exe. It will generate Gw2.dat and Gw2.tmp and then crash at 10128kb.
3) rename Gw2.tmp to Gw2(2).exe
4) run Gw2(2).exe
5) repeat steps 3 and 4 until it works

If you can't find Gw2.tmp then use the windows search feature to find it and move it to the directory you want the final game to install to.
It was the 3rd time I tried renaming the file and running it that it started to work for me. I say "started" because it's finally trying to download the entire client. It hasn't finished yet and won't for hours.

Note: If you stop the download, the megs downloaded will start from 0 again. However I've noticed that Gw2.dat isn't resetting and is growing in file size. The "files remaining" is also showing progress is saved if it's shut down. The files on the DVD game discs appear to be useless. Stopping and restarting the download multiple times caused the error to repeat and I had to wipe everything and start from scratch. I successfully restarted it a few times but it was a highly repeatable crash. You are rolling the dice if you can start it again. So do not stop the download once you get it working.

There's a login screen too which kinda worked. It sent an authentication email to my email account. The authentication link in that email did not work. So... /shrug. EDIT: Apparently that is a known issue and unnecessary. That problem can be ignored.

It's a solution that does something more than what it was doing. I have no idea if it will result in a playable game. But it at least started doing something.

Edited by brunpal, 30 August 2012 - 06:11 AM.


#16 Haz_6

Haz_6

    Pale Tree Seedling

  • New Members
  • 10 posts

Posted 29 August 2012 - 10:59 AM

Is there anyway of downloading the .dat and .tmp files separately from the main client setup?.. a long shot but may help?

#17 brunpal

brunpal

    Fahrar Cub

  • Members
  • 24 posts

Posted 29 August 2012 - 03:18 PM

View PostHaz_6, on 29 August 2012 - 10:59 AM, said:

Is there anyway of downloading the .dat and .tmp files separately from the main client setup?.. a long shot but may help?
Depends on what you define as the "main client setup." Any of these could be called the main client setup because there's no single thing that sets up the the main client.

Gw2Setup.exe = 20.7meg
It can only be downloaded as a separate stand alone file.

Gw2.tmp = 20.9meg
This is the new main client setup. Renaming it and massaging it until it works will start to download the client data. It never increases past 20.9meg

Gw2.dat = 0 bytes to multiple Gig
This file will be zero bytes until you get Gw2.tmp to start to work. Then it will start to tick up.

Any of the above could be considered the main client setup.

I have found many requests to download the main client (not setup) directly in order to set it up after the fact. Nobody has gotten anything like that to the best of my knowledge. (And I think that was your real question.) Also I've yet to see anyone get any sort of reply from Arenanet to their ticket on this issue. And apparently tickets were submitted weeks ago when people had these issues with the beta.

#18 OpsGirin

OpsGirin

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 30 August 2012 - 03:48 AM

Hey, I was having the exact same problem today, but when I renamed Gw2Setup to Gw2.tmp and dragged it to my desktop it worked. Honestly it doesn't really sound like a logical fix, but it worked for me. =p

#19 end07

end07

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 30 August 2012 - 10:28 AM

Just made an account to post the following things which worked for a friend of mine having this exact problem. It seems that when the launcher hangs at 0k/s it's actually waiting for a dialogue window (press ok to allow / continue etc) which fails to appear. After a frustrating day of troubleshooting this is how we got it working.

1. Install all Windows Updates and let everything configure.
2. Do a fresh graphics driver install (Nvidia, single card. May not be relevant).
3. Install from desktop (again, maybe not relevant).

The big thing seems to be the windows update, so give that a go. Hope this helps!

#20 Galstrom

Galstrom

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 30 August 2012 - 06:02 PM

View PostHavencha0, on 29 August 2012 - 01:44 AM, said:

Alright I figured it out and it worked for me, so what you have to do is go to start and right click computer and go to properties after that go to advanced and it should be under performance and then you click advance. The screen should be at performance options go to virtual memory and click change set the page file to system manage and you should be able to download.


Explains it a hell lot better than me: http://www.guildwars...ng-beta-client/

Strangely, I managed to buy myself ten extra seconds and pick my installation folder by doing this. Alas, it still is freezing.

#21 Thndrstd

Thndrstd

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 31 August 2012 - 12:29 AM

I'm having the same issue.  If anyone has any further ideas, please post.

#22 Haz_6

Haz_6

    Pale Tree Seedling

  • New Members
  • 10 posts

Posted 31 August 2012 - 12:56 AM

Bump, I still need help :/

#23 Anarch_Angel

Anarch_Angel

    Fahrar Cub

  • Members
  • 28 posts

Posted 31 August 2012 - 01:17 AM

I'm having the same problem as well; I've tried all kinds of things, and the suggestions in this thread haven't worked out so far.

View Postbrunpal, on 29 August 2012 - 07:07 AM, said:

I have a solution:

1) Download Gw2Setup.exe using your web browser
2) Run Gw2Setup.exe. It will generate Gw2.dat and Gw2.tmp and then crash at 10128kb.
3) rename Gw2.tmp to Gw2(2).exe
4) run Gw2(2).exe
5) repeat steps 3 and 4 until it works

I've actually had to do this from the start, but it's come with the problem of having to re-download the aforementioned GW2.tmp file every time there's a new patch added to the update server (otherwise the game fails to patch and crashes).  Personally it's not been a viable fix as a result, even though I've managed to get the game running a couple of times.

#24 Llessue

Llessue

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 31 August 2012 - 01:42 AM

So I went and bought a box copy of the game today, but I still have to download the entire game?

I am having this error as well, just installing from disc.

Edit:

I went into the Temp folder, renamed the tmp file to exe and ran it. That gave me an alternate splash screen which at least allowed me to create an account. I will keep updating as I go on.

Can anyone tell me what the point of buying the box copy is? I could have just downloaded it.

Edited by Llessue, 31 August 2012 - 01:59 AM.


#25 stekeren

stekeren

    Pale Tree Seedling

  • New Members
  • 2 posts

Posted 31 August 2012 - 03:32 AM

Having exactly the same problem, with Mac OS X Lion, running Windows 7 Ultimate 32 Bit with Bootcamp.

Please help to fix this problem.

#26 UrbanNinja67

UrbanNinja67

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 02 September 2012 - 01:53 AM

View Postbrunpal, on 29 August 2012 - 07:07 AM, said:

I have a solution:

1) Download Gw2Setup.exe using your web browser
2) Run Gw2Setup.exe. It will generate Gw2.dat and Gw2.tmp and then crash at 10128kb.
3) rename Gw2.tmp to Gw2(2).exe
4) run Gw2(2).exe
5) repeat steps 3 and 4 until it works

What if my Gw2.tmp file is emptied after the launcher crashes? Because that's what happens to me, so changing it to an executable wont work.

Edited by UrbanNinja67, 02 September 2012 - 01:55 AM.


#27 brunpal

brunpal

    Fahrar Cub

  • Members
  • 24 posts

Posted 03 September 2012 - 09:49 AM

@urbanNinja67: You could try process locking the file so it's unable to delete it. You could try mirroring the drive so it's unable to delete it. You could also undelete the file. Each of those suggestions would require separate programs.

Best bet is the undelete. The data is still there on your hard drive after it's deleted. "Delete" really means "free up for future use" like painting over an old canvas. If you don't paint over it with new data, the old data is still very readable.

@Llessue: There is zip, zero, nadda, no reason at all to buy the boxed copy.

@Anarch_Angle: Yes these workarounds are getting to be ridiculous.

#28 brunpal

brunpal

    Fahrar Cub

  • Members
  • 24 posts

Posted 11 September 2012 - 11:04 AM

SOLUTION UPDATE:

I've solved the problem with having to use workarounds to patch the game, and expect the problems with installing too but I haven't tested it.  I no longer have to rename gw2.tmp etc to get things to work. I updated my root certificates and now everything seems to work. Also my Trading Post was previously blank and it started working too as soon as I did this update.

Update for Root Certificates For Windows [April 2012] (KB931125)
http://download.micr...9F/rootsupd.exe

This update is for WinXP but apparently it's the same for all versions of Windows. I've only tested it on XP.

You can also update it via going into your control pannel, add/remove programs, changing your windows components, and then ticking the checkbox to update root certificates. THEN running windows update. But that's far more trouble than downloading and running the small file linked above.

#29 Jennius

Jennius

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 14 September 2012 - 05:39 PM

I have found a solution!! I'm also running bootcamp Windows 7 on mac. My first launcher screen would load but the second screen would just be stuck at 0. I've tried EVERYTHING I read on forums but nothing worked besides this:

-While on windows, go to command prompt. (start > type in 'command prompt' in search bar > open command prompt).
-type in "net user administrator /active:yes" (without quotations) then hit enter.
-restart your computer and log in to administrator
-insert snow leopard disc (mac osx install disc) and double click on the cd. This will install bootcamp 3.0 on your computer.
-restart and log back into your account
-open command prompt again and type in "net user administrator /active:no" and press enter. (this removes admin account)
-then download the guildwars2setup file on guild wars site
-once downloaded, rename the guildwars2setup file to gw2.exe
-drag gw2.exe to deskop and run as administrator

Hopefully now the launchers will work and the game will be downloading!!

#30 BrewCrew

BrewCrew

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 15 September 2012 - 03:10 AM

View Postbrunpal, on 11 September 2012 - 11:04 AM, said:

SOLUTION UPDATE:

I've solved the problem with having to use workarounds to patch the game, and expect the problems with installing too but I haven't tested it.  I no longer have to rename gw2.tmp etc to get things to work. I updated my root certificates and now everything seems to work. Also my Trading Post was previously blank and it started working too as soon as I did this update.

Update for Root Certificates For Windows [April 2012] (KB931125)
http://download.micr...9F/rootsupd.exe

This update is for WinXP but apparently it's the same for all versions of Windows. I've only tested it on XP.

You can also update it via going into your control pannel, add/remove programs, changing your windows components, and then ticking the checkbox to update root certificates. THEN running windows update. But that's far more trouble than downloading and running the small file linked above.


Downloading but nothing happens after that. Won't open, i have windows 7. please help




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users