Jump to content

  • Curse Sites
Help
- - - - -

ISP & GW2 account(website), client not getting along. ISP says it's GW2. Need input

isp client account password

  • Please log in to reply
No replies to this topic

#1 Kosh401

Kosh401

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 29 August 2012 - 09:17 PM

Hi everyone, I'm hoping some of you can provide some insight/feedback on this issue while we wait for support to reply someday.

TL;DR my friends ISP told him the reason he can't sign into GW2's account website or game client is something on GW2's end, not theirs. He can connect fine on the same laptop from a store's WIFI, but not his own ISP at home. WTF?

My friend and I both prepurchased but my friend hasn't been able to play at all yet. It's working fine for me.

He has been unable to log into his account on the webpage, he's reset his password successfully and it kept saying login failed. Google found reports of this from Beta, but no solutions.

For shits and giggles, I tried logging into his account on my computer (in a different town, different ISP) and it worked. Once he had the client downloaded, he tried logging into that - still no dice.

Since I wasn't going to be up in his area for a few weeks to try it on my laptop, which works here, on his internet, I suggested he try a local WIFI location to see if he can sign in on his laptop. We had already tried bypassing his router, etc.

Well that worked. From the WIFI in town, he was able to log into his account on his laptop. So this told me it was an ISP issue. He lives in a rural area and gets his highspeed over a radio receiver, and it's actually pretty decent quality/speed for what it is. Battlefield 3 etc is totally playable.

But his ISP is a smaller operation, and the guy on the phone told him the problem is on Guild War 2's end, and not theirs; he said nothing is being blocked on my friends connection, and this tech guy said he was actually playing GW2 himself with the same ISP, although in a different town (which would be a different "node" if I understand this stuff right? so could that be the problem, my friend's "node" in his area is blocking it?)

Anyway now I'm pretty confused. What this tech guy just too lazy to alt tab out of the game to do his job or is there really something up with GW2 that could be causing my friend to have no access to their website or game client??? EDIT: I shoudl word this as, could there really be somethign on GW2's end that is blocking access to/from my friend's ISP, and not the other way around?

While we're waiting for NCSoft/Anet support tickets, and since the official forums are still down, does anyone here have any thoughts/suggestions/experience to share?

Thanks in advance

Edited by Kosh401, 29 August 2012 - 09:22 PM.






Also tagged with one or more of these keywords: isp, client, account, password

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users