Jump to content

  • Curse Sites
Help
- - - - -

Blurry Trading Post Text


  • Please log in to reply
8 replies to this topic

#1 darthlight

darthlight

    Pale Tree Seedling

  • Members
  • 2 posts
  • Server:Henge of Denravi

Posted 03 September 2012 - 02:06 PM

Does anyone else have blurry trading post text (as shown in the attachment)?

This usually happens when "Mipmap Detail Level" is set to "High Performance" on Catalyst on other games; however, currently it is set to "High Quality"

The text is still blurry even if I change the ingame quality to high or low.

I'm running a Radeon HD 4670 (Catalyst 12.6) with a Core i3 540.

Attached Files



#2 Mates1500

Mates1500

    Pale Tree Seedling

  • New Members
  • 4 posts

Posted 03 September 2012 - 05:28 PM

I have radeon HD 4870 with core 2 duo E7400 and experience the same problem

#3 Quaker

Quaker

    Technician

  • Technicians
  • 3341 posts
  • Location:Canada
  • Profession:Ranger
  • Guild Tag:[n/a]
  • Server:Fort Aspenwood

Posted 03 September 2012 - 05:54 PM

It looks just like the sort of effect you get when the in-game resolution setting does not match your monitor's native resolution.

It looks as though the rest of the screen is alright, but I have to ask - are you running the game at some non-native rez?

Also, I'm not sure where this "Mipmap detail level" setting is in CCC,  but if you can, you should probably set it to "Let the application decide" or whatever.

(Edit - apparently the Mipmap setting doesn't appear, depending upon your video card, even though a search says it's in 3D application settings. :huh:  )

Edited by Quaker, 03 September 2012 - 06:00 PM.


#4 vamprocillin

vamprocillin

    Asuran Acolyte

  • Members
  • 105 posts
  • Location:Canada
  • Server:Northern Shiverpeaks

Posted 03 September 2012 - 07:20 PM

I had that before at the correct resolution. I solved it by switching the interface size from small to normal.

#5 ahamling27

ahamling27

    Pale Tree Seedling

  • Curse Premium
  • Curse Premium
  • 5 posts
  • Guild Tag:[CRS]
  • Server:Jade Quarry

Posted 04 September 2012 - 03:22 PM

View Postvamprocillin, on 03 September 2012 - 07:20 PM, said:

I had that before at the correct resolution. I solved it by switching the interface size from small to normal.
I had the same problem, this fixed it for me. I hope they implement proper UI scaling, text included soon. The UI is too big at default settings but turning it down makes some UI text almost unreadable at best.

#6 Magi

Magi

    Asuran Acolyte

  • Members
  • 150 posts
  • Location:Canada
  • Guild Tag:[X]
  • Server:Yak’s Bend

Posted 04 September 2012 - 05:24 PM

View Postahamling27, on 04 September 2012 - 03:22 PM, said:

I had the same problem, this fixed it for me. I hope they implement proper UI scaling, text included soon. The UI is too big at default settings but turning it down makes some UI text almost unreadable at best.

I *just* started experiencing this after they put the TP back up during last night's (this morning's?) build.

#7 Miyagui

Miyagui

    Pale Tree Seedling

  • New Members
  • 1 posts

Posted 11 September 2012 - 06:19 AM

Fixed by switching to normal. Why would they put the option for a small GUI if it would look like that?

#8 Quaker

Quaker

    Technician

  • Technicians
  • 3341 posts
  • Location:Canada
  • Profession:Ranger
  • Guild Tag:[n/a]
  • Server:Fort Aspenwood

Posted 11 September 2012 - 02:53 PM

I was wondering if this may have a connection to supersampling. If you have Render Sampling set to supersample, try setting it to 'native'.

Edited by Quaker, 11 September 2012 - 02:55 PM.


#9 Lord Sojar

Lord Sojar

    Mesmer of Death

  • Site Contributors
  • 2111 posts
  • Location:Inside your GPU, ohaidar
  • Profession:Mesmer
  • Guild Tag:[Heil]
  • Server:Maguuma

Posted 11 September 2012 - 06:31 PM

Actually, I figured out the issue with this as well, a few days ago in fact.  Awesomium isn't dealing with the TMDS module in a proper way.  For whatever absolutely stupid reason, Awesomium attempts to handle TMDS commands natively, and so it's pushing the Hsync bits applied through the DAC at a bad render resolution.  An INF edit would fix this, but alas, GW2 has no INF to configure.  

The scaling shouldn't be running through the DAC that way.  It's something that ANET desperately needs to patch, via Awesomium.  For now, set the scaling to normal and it should fix it, because at native scale, HSync ratio is maintained.  However, turning it to small, Awesomium is making a bad controller link, and is receiving a bad resolution scale because its cramming the wrong signal path down the TDMS's throat.  

This issue doesn't appear on RAMDAC (or rather vRAMDAC nowadays) based display outputs, since those must be written to SRAM first.  So, VGA connections are functioning fine for this, but any digital I/O solution will have this issue due to the use of DAC bypass.  


TL;DR:  Awesomium is broken in GW2 because it handles digital signals and analog signals differently.  Digital signals aren't being scaled properly, and it's causing the blurry text due to under rendering.  

I'll do my best to see this fixed, but I can only do so much.  Srys guys.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users