Jump to content

  • Curse Sites
Help
- - - - -

Help! - Computer black screens while playing!

black screen help fix

  • Please log in to reply
14 replies to this topic

#1 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 03 November 2012 - 09:05 AM

So ive been playing guild wars 2 for about a month now, nd i have only had my pc (which i built) for about 2 months, yet guild wars 2 repeatedly crashes while playing, and occasionally on startup.

I cannot recover from the crash, as i have no control after them the screen becomes totally black, sometimes whit, and i have no mouse pointer or anything.

I have the latest drivers, and it is not heat as i have been monitoring my heat with msi afterburner, and all heat is normal.

Please reply soon, this is really P***ing me off.

#2 Zerk2012

Zerk2012

    Vanguard Scout

  • Members
  • 431 posts

Posted 03 November 2012 - 12:14 PM

View Postolliethecool, on 03 November 2012 - 09:05 AM, said:

So ive been playing guild wars 2 for about a month now, nd i have only had my pc (which i built) for about 2 months, yet guild wars 2 repeatedly crashes while playing, and occasionally on startup.

I cannot recover from the crash, as i have no control after them the screen becomes totally black, sometimes whit, and i have no mouse pointer or anything.

I have the latest drivers, and it is not heat as i have been monitoring my heat with msi afterburner, and all heat is normal.

Please reply soon, this is really P***ing me off.

Thats not much information to go on. The crash log would do wonders but if your PC crashes on startup you have problems. Did you run a stress test on the PC after building it and actually monitor all the temperatures? First thing I would do is if your overclocking set everything back to stock speeds and make sure your memory timmings are set right in BIOS.

#3 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 03 November 2012 - 01:07 PM

View PostZerk2012, on 03 November 2012 - 12:14 PM, said:

Thats not much information to go on. The crash log would do wonders but if your PC crashes on startup you have problems. Did you run a stress test on the PC after building it and actually monitor all the temperatures? First thing I would do is if your overclocking set everything back to stock speeds and make sure your memory timmings are set right in BIOS.

it dosent crash on the startup of the pc it crashes on startup of gw2. i have also been monitoring my temps since i finished the pc and all are norm

#4 Tr3LoS

Tr3LoS

    Fahrar Cub

  • Members
  • 28 posts
  • Location:Home
  • Guild Tag:[GRC]
  • Server:Aurora Glade

Posted 03 November 2012 - 01:16 PM

Could you post your Mobo, Ram, CPU? Have you overclocked your PC?

It should not be a hardware failure from my knowledge.

Also can you Alt+Tab, Alt+Cntrl+Del, Cntrl+Shift+Esc when having the black screen?

Edited by Tr3LoS, 03 November 2012 - 01:47 PM.


#5 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 03 November 2012 - 03:35 PM

My mobo is gigabyte GA-Z77-D3H, my ram is corsair vengence 8gb, and my cpu is intel i5 ivybridge. My gpu is a evga nvidia geforce gtx 560 ti.

Also this dosent seem to be just in guild wars, sometimes it cant even reach the desktop.

#6 Quaker

Quaker

    Technician

  • Technicians
  • 3371 posts
  • Location:Canada
  • Guild Tag:[n/a]

Posted 03 November 2012 - 04:00 PM

There's not much to go on and it could be a lot of things. You could simply have a bad component.

Make sure everything is properly set in the BIOS - reset the BIOS to be sure.

Make sure all your drivers are up to date.

Make sure that all fans are running properly.

Is the power supply big enough?

etc..... :)

#7 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 03 November 2012 - 04:52 PM

I believe the power supply is big enough, my drivers are all up to date, i havent changed anything in the BIOSand im pretty sure allt he fans are running.

#8 Zerk2012

Zerk2012

    Vanguard Scout

  • Members
  • 431 posts

Posted 03 November 2012 - 05:06 PM

View Postolliethecool, on 03 November 2012 - 04:52 PM, said:

I believe the power supply is big enough, my drivers are all up to date, i havent changed anything in the BIOSand im pretty sure allt he fans are running.

This seems to be going in circles with misinformation ( "sometimes it cant even reach the desktop").  Did you ever go into bios and set the memory timmings or check if they were set right?

#9 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 03 November 2012 - 05:56 PM

Look im not very good with computers, so when i went into the memory timings as you said i have no idea what im looking for and just leave it alone, if you could tell me about the memory timings that would actually be usefull.

#10 Tr3LoS

Tr3LoS

    Fahrar Cub

  • Members
  • 28 posts
  • Location:Home
  • Guild Tag:[GRC]
  • Server:Aurora Glade

Posted 03 November 2012 - 09:45 PM

Quote

sometimes it cant even reach the desktop

Wow, you don't give all the info at once. Can you explain what happens and it "can't reach the desktop"? Etc. does it freeze at login screen? Does it go into reboot loop? Does it pop a blue screen? Black screen as in game?

I also start to speculate corrupted Windows there, but there could be a lot of problems. If you can, check how much your power supply is (It says it from behind or if you pop the casing and check under, front, rears of the PSU).

Your rams should run at 1600Mhz if I have checked it correctly and their timings are 8-8-8-24. Check it in your BIOS.

Quote

Also can you Alt+Tab, Alt+Cntrl+Del, Cntrl+Shift+Esc when having the black screen?

And after all this I told, I have to say that I don't think it is a hardware problem since it's fine. Oh, and something that came into my mind right now, have you done any updates to your PC before these black screen appear? Installed a program or anything? If yes try to do a restore before the updates or search/tell me what updates/programs were installed.

#11 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 04 November 2012 - 10:06 AM

View PostTr3LoS, on 03 November 2012 - 09:45 PM, said:

have you done any updates to your PC before these black screen appear? Installed a program or anything? If yes try to do a restore before the updates or search/tell me what updates/programs were installed.

No it has happend since i built it, butmy power supply is a corsair 700 watt gaming series.

And when it crahes before he desktop it has the blue windows background (with the plants and stuff) saying loading desktop or whatever, then when the desktop would appear, it just goes black and i get no respons from using my mouse or keyboard, then my screen says "no signal input", and that also happens ingame, but it just randmly happens. And it does not reboot it just stays as a black screen and waits for me to press the on button to restart it.

Edited by olliethecool, 04 November 2012 - 10:07 AM.


#12 Tr3LoS

Tr3LoS

    Fahrar Cub

  • Members
  • 28 posts
  • Location:Home
  • Guild Tag:[GRC]
  • Server:Aurora Glade

Posted 04 November 2012 - 11:17 AM

Well if you haven't done any updates I don't know what the heck it might be. Maybe your resolution of the screen.. See this: http://answers.micro...AllReplies#tabs

Does the computer sound to work normally when this black screen happens? Keyboard/mouse lights on? If not it is not caused by resolution but something else.

Once this happened to me but it was cause of a windows update. I checked the microsoft replies and fixed it. Google some more, try everything you find that matches your problem and maybe ask in a specialized technical forum.

Sorry, but I can;'t help you more:(

#13 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 04 November 2012 - 11:36 AM

Hmm dont know how resolution would cause this but i will try it, when it blacik screens the keyboard stays on, but if i have music in the bg it tears a little but stays on.

#14 Zerk2012

Zerk2012

    Vanguard Scout

  • Members
  • 431 posts

Posted 04 November 2012 - 12:59 PM

View Postolliethecool, on 04 November 2012 - 10:06 AM, said:

No it has happend since i built it, butmy power supply is a corsair 700 watt gaming series.

And when it crahes before he desktop it has the blue windows background (with the plants and stuff) saying loading desktop or whatever, then when the desktop would appear, it just goes black and i get no respons from using my mouse or keyboard, then my screen says "no signal input", and that also happens ingame, but it just randmly happens. And it does not reboot it just stays as a black screen and waits for me to press the on button to restart it.

Thats the information I was looking for List the exact video card and memory you bought a link would do good.
This sounds like a simple video card driver issue, or improper seating/timmings of the memory.

EDIT also list the mother board, and operating system.

Edited by Zerk2012, 04 November 2012 - 01:18 PM.


#15 olliethecool

olliethecool

    Pale Tree Seedling

  • New Members
  • 8 posts

Posted 05 November 2012 - 09:10 PM

Oh sorry i think it was heat, but i do now have to have my fan on 70% to actually stop it from overheating





Also tagged with one or more of these keywords: black screen, help, fix

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users