Jump to content

  • Curse Sites
Help
- - - - -

Massive FPS drops with new update


  • Please log in to reply
9 replies to this topic

#1 kanaxais_scythe

kanaxais_scythe

    Asuran Acolyte

  • Members
  • 92 posts

Posted 27 February 2013 - 05:06 PM

Anyone have issue with fps drops in AC? Everyone in my guild does now. i have a 2gb gtx680, i7 at 3.5ghz, and 24gb of RAM and during path 2 and three i get drops as low as 10 fps during certain times. everywhere else in the game is perfect with 60-120 fps.

#2 Dainjah

Dainjah

    Fahrar Cub

  • Members
  • 30 posts
  • Location:UK

Posted 27 February 2013 - 05:12 PM

My guildies and I experienced this once or twice last night (shortly after the update itself), especially during path 2 (Detha) at the part with all the gravelings and spike traps, was like watching a slideshow on Powerpoint for a while it was so jumpy. Assumed at the time it was due to server lag/stress with everyone downloading the update, or the fact that AC was probably hugely busy what with the changes and everyone wanting to try it out.

Edited by Dainjah, 27 February 2013 - 05:13 PM.


#3 Azure Skye

Azure Skye

    Golem Rider

  • Members
  • 2099 posts
  • Location:(づ。*◕__◕。)づ・。*。✧・゜゜・。✧・。*。✧ Magic!
  • Profession:Mesmer
  • Guild Tag:[CUTE]
  • Server:Dragonbrand

Posted 27 February 2013 - 05:23 PM

Actually, I'm getting better Fps. Oh by the way,did you update your drivers?

#4 kanaxais_scythe

kanaxais_scythe

    Asuran Acolyte

  • Members
  • 92 posts

Posted 27 February 2013 - 05:24 PM

i can double check for newer ones but yes I am sure i am on the newest ones.

#5 RaoulDukeHST

RaoulDukeHST

    Sylvari Specialist

  • Banned
  • 515 posts
  • Guild Tag:[EXG]
  • Server:Desolation

Posted 27 February 2013 - 05:36 PM

it's server related,it will go away as the surge of people that came with the patch calms down

#6 Ernest1337

Ernest1337

    Fahrar Cub

  • Members
  • 15 posts

Posted 27 February 2013 - 05:48 PM

View Postkanaxais_scythe, on 27 February 2013 - 05:06 PM, said:

Anyone have issue with fps drops in AC? Everyone in my guild does now. i have a 2gb gtx680, i7 at 3.5ghz, and 24gb of RAM and during path 2 and three i get drops as low as 10 fps during certain times. everywhere else in the game is perfect with 60-120 fps.

yup P2 during the traps part. 10 fps

#7 Rukioish

Rukioish

    Sylvari Specialist

  • Members
  • 604 posts
  • Location:Black Citadel
  • Profession:Ranger
  • Guild Tag:[OMNI]
  • Server:Ferguson’s Crossing

Posted 27 February 2013 - 05:49 PM

View Postkanaxais_scythe, on 27 February 2013 - 05:06 PM, said:

\ 24gb of RAM \

Jesus, what.

#8 Darkobra

Darkobra

    Seraph Guardian

  • Members
  • 1366 posts
  • Location:Scotland

Posted 27 February 2013 - 08:09 PM

People use RAM for things outside of gaming too.

#9 rukia

rukia

    Sylvari Specialist

  • Members
  • 604 posts
  • Location:Oregon
  • Profession:Thief
  • Server:Kaineng

Posted 27 February 2013 - 09:19 PM

I'm getting more culling issues, I tried doing melandru event and couldn't even target the mobs because they were all invisible, along with players. This has always been a problem but not THAT bad. It could just be my comp.

#10 HawkofStorms

HawkofStorms

    Guru's Source of Witty Banter

  • Members
  • 3101 posts

Posted 27 February 2013 - 10:17 PM

I wouldn't even call those culling issues.  It feels more like bad texture pop-in, which I'm getting a lot now with this update too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users