Jump to content

  • Curse Sites
Help
- - - - -

Check your Guild Bank, it might be gone.


  • Please log in to reply
3 replies to this topic

#1 TakumiUsui

TakumiUsui

    Vanguard Scout

  • Members
  • 211 posts

Posted 10 May 2013 - 07:33 PM

Hey everyone

I dont know if this is the correct section, but you should really check your Guild Banks.
Somehow my own Guilds Storage is completely gone. The Guild Bank NPC says "Your Guild hasn't build any sort of Storage yet" eventhough we have upgraded all of the available storage upgrades  a long time ago.
We have Items worth 200g+ in there, I hope they wont be gone....
Already wrote a ticket, now waiting for an answer.

Better check your Guild Banks and take out valueable stuff and just in case!

#2 Mister Stygian

Mister Stygian

    Asuran Acolyte

  • Members
  • 113 posts

Posted 10 May 2013 - 08:27 PM

Did your guild change servers by any chance?

#3 Baron von Scrufflebutt

Baron von Scrufflebutt

    Golem Rider

  • Members
  • 3305 posts

Posted 10 May 2013 - 10:38 PM

I think talking to a different guild NPC solved this for me. (If I tried talking to the home server Borderlands guy storage wouldn't show up, but if I jumped to a Borderlands of a server that we were in war with, it showed up.)

#4 Gerroh

Gerroh

    Sylvari Specialist

  • Members
  • 572 posts
  • Location:Ontario, Canada
  • Profession:Necromancer
  • Guild Tag:[Nope]
  • Server:Blackgate

Posted 10 May 2013 - 10:45 PM

It happens frequently. It's not an issue. Usually just relogging fixes it. I haven't tried talking to a different guild NPC, but that might work, too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users