Jump to content

  • Curse Sites
Help
- - - - -

Guild Wars 2 Lowering CPU Clock Speed

guildwars2 fps cpu clockspeed

  • Please log in to reply
7 replies to this topic

#1 LogramAce

LogramAce

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 25 December 2013 - 04:40 PM

Not sure if this is the right place, but I'll go for it.

I've been playing Guild Wars 2 for a while, and have recently switched to using my laptop more.

Specs:
HP Pavillion DV6 6011tx Laptop
Intel Core i7 2630QM @2.0GHz
AMD Radeon 6700M
8GB Ram
320GB SSD

Now, most games I run on my laptop works fine at medium to low settings at stable 50-60fps. When I started up Guild Wars 2 though, it would not go higher than 20-30fps, and would dip to below 10fps in Lions Arch.

This was strange, so I checked task manager, and it was only running at 15% CPU speed, about 800Mhz to 1100Mhz. I changed priorities and everything, but it wouldn't go higher. After a bit of research, I discovered the "Unpark CPU" trick. Downloaded it, checked, and they were already unparked. I tried again, and it was the same.

I know that it wasn't my video card, because GPU-Z showed that it was running properly, and I read that GW2 is very CPU intensive, which is why I was confused on why my CPU wouldn't speed up.

I researched a bit more, found ThrottleStop 6.0, configured that, and everything. While writing this, my throttlestop says the PC is running at 1600MHz-1900MHz. This is when I'm not running Guild Wars 2, and when I ran and was playing other games, it even turbo boosted. Now, when I ran GW2, after 2 minutes, my CPU speed would go back to 800MHz-1100MHz.

I attached some screenshots, with the game running and not running.
Not running:
Attached File  nogw2.jpg   118.98K   34 downloads

Running:
Attached File  withgw2.jpg   127.87K   33 downloads

Any idea what the problem might be?

#2 Kattar

Kattar

    Your Shoulder to Cry On

  • Administrators
  • 2169 posts

Posted 25 December 2013 - 05:06 PM

View PostLogramAce, on 25 December 2013 - 04:40 PM, said:

snip
Moved to the more correct section. Thanks!

You are fooling yourself, user. Nothing here is what it seems. ANet is not the plucky hero, Guru is not an evil empire, and this is not the grand arena.



Questions about moderation? For the love of Balthazar ask them here!


#3 tijo

tijo

    Technician

  • Technicians
  • 3169 posts
  • Guild Tag:[RISE]
  • Server:Stormbluff Isle

Posted 25 December 2013 - 10:14 PM

Just by looking at the temps, the answer seems simple: you're hitting thermal throttle. It's time to get an aircan and clean those vents.

Also, make sure your powerplan is set to balanced or high performance.

Edited by tijo, 25 December 2013 - 10:15 PM.


#4 LogramAce

LogramAce

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 26 December 2013 - 02:31 PM

@Kattar, thanks for moving it over.

I cleaned my laptop yesterday, completely disassembled, snuffed out the vents, the fan, a lot of dust and am running it on a laptop cooler(Cooler Master something edition) and I'm getting lower temperature readings. When not playing Guild Wars 2, I get about 1900Mhz-2200Mhz at the moment, temperature stays constant at 84'c (which I know is high, but it's better than before), but when I do play Guild Wars 2, it throttles down to 800MHz-900MHz. It might just be my laptop though, but I still can't figure out why it's happening when I run GW2. Any other suggestions guys?

#5 Quaker

Quaker

    Technician

  • Technicians
  • 3244 posts
  • Location:Canada
  • Profession:Ranger
  • Guild Tag:[n/a]
  • Server:Fort Aspenwood

Posted 26 December 2013 - 04:00 PM

I can think of 2 things atm (maybe more later :) )

1. The temperature still seems a bit high. It could be that the cooler is not sitting on the CPU properly, or that the thermal paste has dried up and not working properly. There could also be a fault on the motherboard that is improperly relaying the temperature to the OS, causing the OS to throttle back the CPU.

2. Do you have some sort of graphics switching program installed, such as LucidLogix's Virtu? If so, make sure it is set to use the 6700M during GW2 and not the CPU's integrated graphics.

#6 LogramAce

LogramAce

    Pale Tree Seedling

  • New Members
  • 3 posts

Posted 26 December 2013 - 04:26 PM

My laptop does have switchable graphics, but I have that feature disabled through the BIOS settings. It shouldn't be the thermal paste, since I re-applied some about a month ago. Thanks for the suggestions though

#7 Elder III

Elder III

    Technician

  • Technicians
  • 4424 posts
  • Location:OH
  • Guild Tag:[ION]
  • Server:Jade Quarry

Posted 28 December 2013 - 06:10 AM

I agree with Tijo - it looks like it's overheating based on those temps.  Try a laptop cooling pad or even propping a book under the backedge so that there is better airflow under the laptop.... check for dust filled vents or broken fans too.  Try those options and run another temperature test to see if it drops it ~10 C for you.

#8 tijo

tijo

    Technician

  • Technicians
  • 3169 posts
  • Guild Tag:[RISE]
  • Server:Stormbluff Isle

Posted 28 December 2013 - 05:10 PM

I know you said you repasted, it's possible that you put too much paste or that the heatsink wasn't seated back properly. If all else fails, you could go for a repaste again.

Other things that come to mind, BDPROCHOT is throttling GW2 regardless of whether your temps are ok or not, but if you're getting 80-90C at 800 MHz, something is definitely wrong and it's not that. If you're not useing the original power supply, maybe the other isn't capable of providing enough power.

Edited by tijo, 28 December 2013 - 05:12 PM.






Also tagged with one or more of these keywords: guildwars2, fps, cpu, clockspeed

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users