Jump to content

  • Curse Sites
Help

Unfinished91

Member Since 15 Jan 2012
Offline Last Active Jan 22 2013 10:33 AM

Posts I've Made

In Topic: What do GW1 players think of GW2?

22 January 2013 - 09:18 AM

View PostGileas898, on 22 January 2013 - 06:14 AM, said:

For me, the answer is "Yes" to a much greater extent in GW1 than what it is in GW2. Thinking Ascalon was "it", and being surprised when you got to the Shiverpeaks, hearing all those little memorable quotes by Cynn, the epic ambient sounds in Old Ascalon, getting lost trying to reach Piken Square, chilling in Fisherman's Heaven, hanging out in the "lost" hub Henge of Denravi, getting to the Crystal Desert and hearing the gossip of how Amnoon Oasis is the last source of water for along time, thinking Thunderhead Keep was the end of Prophecies, the list just keeps going on.

I have the same feeling. I have loved Gw1 story. I was younger, that's true, but even now I belive it had something magic. All those place you named are in my heart. Gw2 is a good game and sometime I play too, but Gw1, above all at start, was not just good: it was epic.

In Topic: Abyssal Scepter Recipe Bugged, A-Net says "oh well"!

18 October 2012 - 02:46 PM

I'm sorry for you. :( I hope they'll be able to help you in one way or another.

In Topic: The monthly achievement

05 September 2012 - 08:21 PM

Is it still bugged at this moment? :)

In Topic: Low FPS Issue - Tracking The Problem

27 August 2012 - 05:00 PM

Windows 7 ultimate 64
Intel Q8200 2.33 ghz
Gpu Ati Radeon 4870
4 gb ram DDR 2
Firstly, I want to say that my GPU works with every other game but GW2 ( it worked during stress tests and BWE ).
My brother has a 4870 ati too and he gets 40/60 fps with res 1920x1080.
If I use his GPU with my pc, it works good too.
I don't understand what's the problem; I have tried everything: uninstall drivers, format my pc et cetera.

In Topic: Low fps that spikes lower

26 August 2012 - 12:26 PM

I have the same problem.
Gpu ati 4870
Cpu quad core Q8200
Resolution 1440x900
Is it possible nobody has found a solution yet? :(